Outdated Browser Versions

Background

We do not support Internet Explorer version 7 or earlier.  This is an outdated browser that is no longer supported by the standards of the internet.  You can see the statistics here - http://www.w3schools.com/browsers/browsers_stats.asp which shows you that only 20% of the internet uses Internet Explorer.  Of that group, only 3% use Internet Explorer 7.  This means that less than 0.5% of ALL internet users are using that browser and that is why it is no longer supported.

Upgrade to Internet Explorer 8

Anyone using Internet Explorer 7 can freely upgrade to Internet Explorer 8.  Please download and install Internet Explorer 8 here - http://windows.microsoft.com/en-US/internet-explorer/downloads/ie

There is also Internet Explorer 9, but you must at least have either Windows Vista or Windows 7 operating system in order to use it.  (Windows XP can only use Internet Explorer 8).  

Want the Best Experience?  Use Google Chrome

We're big fans of Google Chrome here at IconoSites.  It's just a really fast browser, without all the bloated software that you find on Internet Explorer.  And, it will give you the best experience when you are surfing the web and using IconoSites.  Download Google Chrome

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk